Ad Widget

Collapse

Announcement

Collapse
No announcement yet.
X

GSXF 750 speedo?

Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • GSXF 750 speedo?

    Ok I am having a problem that when I have gone to change my clocks it has come up saying that the bike is moving on the new clocks when plugged in (mph gauge goes to roughly 15mph) and ignition is on, I dont know what the problem is as the wiring all looks ok, also the clock on the new speedo doesn't work, any help?

    http://imgur.com/a/HrhRx

    Just for reference the clocks that came on the bike was in KPH and also didnt have the digital clock on the bottom right, only a fuel gauge and a suzuki logo
    Last edited by Katana 750 Rider; 05-06-2017, 06:27 PM.

  • #2
    Hmmm, wrong year or speedo malfunction. Could also be electrical noise the speedo is picking up. Unplug the speed sensor and see if it drops to zero. Maybe a sensor issue. I believe the clock has a battery in the back of it.
    "I'm sorry, I didn't mean to upset you when I called you stupid. I thought you already knew..."
    spammer police
    USAF veteran
    If your a veteran, join the KR veterans group

    Comment


    • #3
      Do what 92x say's. Also what year is your bike? If it falls into the right year range there is possibly a short some where.
      2002 750 Kat
      2013 Polaris 850 XP LE(wrecked)
      2002 Ski-Doo MXZ 800
      2002 Ski-Doo MXZ 800 X-package
      1999 Ski-Doo MXZ 670 H.O.
      2009 Kawasaki KX250F(SOLD)

      Comment

      Working...
      X