Ad Widget

Collapse

Announcement

Collapse
No announcement yet.
X

Led turn signal not fully lighting up

Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Led turn signal not fully lighting up

    I'm pretty sure some one probably all ready posted an answer to this question but i couldn't find it. My problem is i just got new led signals and when i hook them up only three of the 18 leds light up. Is this a resistor problem or what?
    If things aren't going your way your in the WRONG LANE!

  • #2
    test the led's directly on a battery, make sure they work
    Blood , its in you to give! http://www.blood.ca/

    Comment


    • #3
      Lights work fine hooked up straight to the battery.
      If things aren't going your way your in the WRONG LANE!

      Comment


      • #4
        what bike is this ?
        I put LEDs on my 04 , flash fast but all light up
        http://katriders.com/vb/showthread.p...25#post1692925

        you could try wiring in with old light bulb , if they all light up you could add a resistor or if it is a pre bike change the signal flasher to an electronic one
        I am thinking with the fast flash rate they jusy dont get a chance to light up

        or you may end up putting on a load equalizer usually used when wiring for trailer lights thats purely a guess though
        Blood , its in you to give! http://www.blood.ca/

        Comment


        • #5
          If you have a volt meter, you could check to see if you are getting full power to the signal. If you are not getting enough power just trace it back until you find the problem.
          92 GSX600F
          67 VW Karmann Ghia (for sale)

          Comment

          Working...
          X