KOTM Aug 2007 chriskat1100
 

Welcome to the KatRiders.com forums.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   KatRiders.com > Suzuki Katana Forums > Suzuki GSXF 650 Talk

Suzuki GSXF 650 Talk A little corner of katriders for the new GSXF 650s.

Reply
 
Thread Tools Display Modes
Old 12-23-2016, 09:58 AM   #1
hwallgsx600f
Skid Mark
 
Join Date: Dec 2016
Location: california
Posts: 2

Question Intermittent Starting Problem with GSX600F

I've recently purchased a new gsx600f and everything works as it should except when I try to start it. After turning the key it all seems fine, lights come on etc.
However when i press the starter sometimes it works absolutely fine first time, however most of the time there is nothing, no noise, no click just silence - leading me to think it is not the battery that's the problem (the lights and all electricals are strong).
Even if I do get it started, if I then turn it off and try again without moving or changing anything it won't work.

Looking forward to riding this one so any advice/tips would be welcome, thanks!
hwallgsx600f is offline   Reply With Quote
Old 12-23-2016, 10:45 PM   #2
Kreylyn
Kat King
 
Kreylyn's Avatar
 
Join Date: Nov 2008
Location: Weaverville, NC
Posts: 15,339
eBay ID: Kreylyn

Default

Quote:
Originally Posted by hwallgsx600f View Post
I've recently purchased a new gsx600f and everything works as it should except when I try to start it. After turning the key it all seems fine, lights come on etc.
However when i press the starter sometimes it works absolutely fine first time, however most of the time there is nothing, no noise, no click just silence - leading me to think it is not the battery that's the problem (the lights and all electricals are strong).
Even if I do get it started, if I then turn it off and try again without moving or changing anything it won't work.

Looking forward to riding this one so any advice/tips would be welcome, thanks!
Step one...

Clean the starter button switch.

Krey
__________________
93 750 Kat



Modified Swingarm, 5.5 GSXR Rear with 180/55 and 520 Chain, 750 to 600 Tail conversion, more to come. Long Term Project build thread http://katriders.com/vb/showthread.php?t=96736

"I've done this a thousand times before. What could possibly go wron.... Ooops!"
Kreylyn is offline   Reply With Quote
Old 12-23-2016, 10:48 PM   #3
92xjunker
Neo-Maxiod-Zoomed-Dweebie
Supporting Member
 
92xjunker's Avatar
 
Join Date: Jun 2011
Posts: 9,989
eBay ID: guysmustang

Default

Agreed.
__________________
"I'm sorry, I didn't mean to upset you when I called you stupid. I thought you already knew..."
spammer police
USAF veteran
If your a veteran, join the KR veterans group
92xjunker is online now   Reply With Quote
Old 03-20-2017, 12:17 PM   #4
Tigran
Skid Mark
 
Tigran's Avatar
 
Join Date: Mar 2017
Location: London
Posts: 5

Default

I had this exact problem not long ago, there's a pin connector thing below the clutch, it makes sure that you have to keep the clutch pressed in when you press the starter button switch. Un-pin it, try cleaning it out a bit cause its probably covered in dirt and such, it might work after that.
Tigran is offline   Reply With Quote
Old 04-11-2017, 06:21 AM   #5
Ding dong
Skid Mark
 
Join Date: Apr 2017
Location: Ansonia
Posts: 2

Default

Rectifier location on my 99. Can't see it anywhere where been looking for hour
Ding dong is offline   Reply With Quote
Old 04-15-2017, 02:44 PM   #6
Tigran
Skid Mark
 
Tigran's Avatar
 
Join Date: Mar 2017
Location: London
Posts: 5

Default

I never noticed it untill a mechanic pointed it out tbh, the cable comes out from the right side of the box thing that controls the turn signals etc. Follow it and it should connect below the cluth. I have an EU model so it's possible your bike dosent have one of those but that would be surprising
Tigran is offline   Reply With Quote
Old 04-15-2017, 03:23 PM   #7
92xjunker
Neo-Maxiod-Zoomed-Dweebie
Supporting Member
 
92xjunker's Avatar
 
Join Date: Jun 2011
Posts: 9,989
eBay ID: guysmustang

Default

Either clutch safety or the starter relay is faulty. Clutch safety switch is on the clutch handle perch. The starter relay is on the left side of the bike under the fairing.
92xjunker is online now   Reply With Quote
Sponsored Links
Reply

  KatRiders.com > Suzuki Katana Forums > Suzuki GSXF 650 Talk

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Intermittent ignition problem crimsontracer Wiring and Electrics 23 07-13-2015 11:28 PM
Intermittent starting Gkannon77 Wiring and Electrics 11 04-05-2014 07:11 PM
Intermittent starting Gkannon77 Wiring and Electrics 0 04-05-2014 12:00 PM
2001 gsx600f starting problem gordo8888 Suzuki Katana Talk 14 09-19-2011 12:49 PM
96 GSX600F starting & running problems... Paladin Mechanics 101 6 05-11-2005 07:22 PM

All times are GMT -5. The time now is 08:17 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Katriders.com, Copyright ©2004 - 2017

Like Cigars? Check out Vitola.org