March
 

Welcome to the KatRiders.com forums.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   KatRiders.com > Service Department > Mechanics 101

Mechanics 101 Can't get it to run right? Find a trick to add HP?
From the first oil change to completely rebuilding the engine,
this is the place to talk about the heart of the beast!


Reply
 
Thread Tools Display Modes
Old 06-25-2008, 04:01 PM   #1
general
Squid
 
Join Date: Nov 2004
Posts: 38

Default Petcock Problem or Carbs Problem

Ok so here is my problem. I decided to take my bike out on a ride today and it died on my during my ride. I have already run about two treatments of carb cleaners thru my bike and about 6 tanks of fuel. If I placed the petcock on Res or On, I can ride the bike for a short period and then it stalls, but if I move the petcock to pri then it will run and run and run. I just pulled my K&N pods off cleaned and oiled them. My bike is a 92 600 Katana. It has a stage 1 (I believe) jet kit, the air pods, and a vance and hines SSR exhaust. Any idea what my problem is?

Thanks in advance for your help
general is offline   Reply With Quote
Old 06-25-2008, 04:42 PM   #2
JBLUE
Kat Master
 
JBLUE's Avatar
 
Join Date: Jan 2007
Location: Brooklyn ny
Posts: 2,836

Default

you running your bike on prime is flooding your plugs thats might be your problem your plugs are foul but you will need carbs work after you change your plugs
__________________
Allan

If you love it, let it go. If it comes back to you, you've high-sided!


JBLUE is offline   Reply With Quote
Old 06-25-2008, 04:42 PM   #3
Tmod
Makes Girly Parts Happy
 
Tmod's Avatar
 
Join Date: Jun 2008
Location: Spud Capital USA
Posts: 2,125

Default

Sounds like a bad petcock assembly to me, Just rebuild it and you should be good to go.

Also check the vacumn line to the petcock to make sure it is not cracked.

Tmod
Tmod is offline   Reply With Quote
Old 06-25-2008, 04:45 PM   #4
Black_peter
--Zombie--
Supporting Member
 
Black_peter's Avatar
 
Join Date: Jan 2005
Location: 85041
Posts: 19,603
eBay ID: caferacer1964

Default

So in ON or RES is dies, but on PRI it runs fin all the time?
Can only mean 3 things..
1. there is an sporadic problem in the vacuum line running to the petcock. So it eventually stops providing enough vacuum to keep the petcock open.
2. the petcock diaphragm is dead/dying
3. thats it really. I was going to say the filter screen is clogged but that would effect PRI the same as ON/RES.

Man of few words Tmod beat me to it! Good job!
Black_peter is offline   Reply With Quote
Old 06-25-2008, 04:47 PM   #5
Vandil
Tank Slapper
 
Vandil's Avatar
 
Join Date: Jun 2008
Location: Madison WI
Posts: 256
eBay ID: criptic

Default

I had the same deal on my bike it was

"2. the petcock diaphragm is dead/dying"
Vandil is offline   Reply With Quote
Old 06-25-2008, 07:09 PM   #6
general
Squid
 
Join Date: Nov 2004
Posts: 38

Default

Great Thanks for the help guys, guess I will do a little searching online to buy a rebuild kit for the Petcock and hopefully that resolves my problem.
general is offline   Reply With Quote
Old 06-25-2008, 08:18 PM   #7
TheSteve
Knee Dragger
 
Join Date: Mar 2008
Location: AZ
Posts: 528

Default

I recall reading (probably from Arsenic) that the K&N pods flow TOO WELL for the petcock to function. Not enough vacuum is allowed to form so the petcock closes. Define "short period" for me. You might just be running off the residual fuel in the bowls, then once that runs out turning it to prime allows them to refill. Just an idea, but it might be worth investigating.
TheSteve is offline   Reply With Quote
Old 06-25-2008, 08:25 PM   #8
Tmod
Makes Girly Parts Happy
 
Tmod's Avatar
 
Join Date: Jun 2008
Location: Spud Capital USA
Posts: 2,125

Default

Quote:
Originally Posted by TheSteve View Post
I recall reading (probably from Arsenic) that the K&N pods flow TOO WELL for the petcock to function. Not enough vacuum is allowed to form so the petcock closes. Define "short period" for me. You might just be running off the residual fuel in the bowls, then once that runs out turning it to prime allows them to refill. Just an idea, but it might be worth investigating.
But if he has been running for awhile with the K&N pods and it ran fine I doubt that is the issue.

It sounds like something that just happened that is causing this problem.

Tmod
Tmod is offline   Reply With Quote
Old 06-25-2008, 08:28 PM   #9
arsenic
Katastical
 
arsenic's Avatar
 
Join Date: Nov 2004
Location: 60505
Posts: 21,184
eBay ID: arsenic1016

Default

still, K&N still sucks
arsenic is offline   Reply With Quote
Old 06-25-2008, 08:38 PM   #10
general
Squid
 
Join Date: Nov 2004
Posts: 38

Default

the short period I am referring to is less than a quarter of a mile while the petcock is set to on or res. Aresnic, what do you recommend other than K & N?
general is offline   Reply With Quote
Sponsored Links
Reply

  KatRiders.com > Service Department > Mechanics 101

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
problem after taking carbs apart delkampg Mechanics 101 7 06-06-2008 11:51 AM
petcock problem punkrex Mechanics 101 3 05-13-2008 10:26 AM
Fuel Petcock....leaking problem... sheldonk Katana How-To's & FAQ's 16 10-02-2007 10:42 AM
Petcock or carb problem? UndrTakr24 Mechanics 101 2 07-19-2006 12:37 PM
Petcock problem TAFNAP Mechanics 101 6 04-24-2006 12:08 PM

All times are GMT -5. The time now is 08:21 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Katriders.com, Copyright ©2004 - 2018

Like Cigars? Check out Vitola.org