PDA

View Full Version : D&D pics and vid


jeffro7172
04-15-2007, 09:18 PM
Posted this in pics and vids too, but here is it in the exhaust section. I didn't look terribly hard, but I wanted to put it on the exhaust sound webpage thread, but I have to get offline. The webpage guy has permission to use it :)

http://jeff.iv.com/katana1sm.jpg
http://jeff.iv.com/katana2sm.jpg

and vid (2mb, slow on some connections)
http://jeff.iv.com/katanadd.mov

KatanaSoldier
04-15-2007, 09:25 PM
Ah, a good loud and rude D & D. I love it!

athlon161
04-19-2007, 02:38 PM
Where is this exhaust sound webpage at? Thanks

theusualsuspect
04-19-2007, 10:59 PM
the page is in the works i havent had mch time to work on it lately due to trying to balance 2 jobs, school, fixing my kat and trying to maintain some of a life (my internet also went down for a week somewhere in there as well :roll: ) but thanks for the permission i will add it as soon as i can

ToMaC
07-04-2007, 01:46 PM
Nice!

06katanacbz
08-05-2007, 10:19 PM
great sound

Rodan
08-06-2007, 08:23 PM
Thanks!
I bought a 06 600
and have been trying to
figure out which exhaust to go with.
And that D&D is what I've been looking
for. Thats the sound

thorne
08-08-2007, 02:39 AM
I love mine. It just gives it a meaner sound.

badroc13
08-09-2007, 01:06 AM
Here is mine for comparison with the stock exhaust
:-D http://img.photobucket.com/albums/0803/badroc/bcb8535d.jpg[/i]

oldgangalee
08-09-2007, 04:08 PM
:shock: sweet jeasus!


:lol: ... man i cant wait for mine to get here.


Hey what jet kit did you use? :?

juggalo_4_life_15
08-09-2007, 06:43 PM
mmmmmm, its hard to beat the sound of a D&D, i want one when i get my bike :D

badroc13
08-09-2007, 09:31 PM
Didnt install a jet kit... it runs fine- just had the 4K service also.. no problems yet






Should have I installed a jet kit with a slip on?

oldgangalee
08-10-2007, 10:12 AM
nah, you dont need a jetkit with a slip on.

LocoKat
08-10-2007, 10:16 AM
I got mine 3 months ago and still in love withthat sound,btw I got the Carbon one